What are the technical requirements to use FollowMyHealth®?

Last Updated: Apr 30, 2019 02:57PM CDT

FollowMyHealth® Universal Health Record is an HTML5 web-based application. It is best viewed in our supported browsers listed below.
> Microsoft® Internet Explorer® 9.0 or later (NOTE: You must use Microsoft® Internet Explorer® 10.0 or later if you want to view goals from the Goals tab)
> Microsoft Edge 42.17134.1.0 or later
> Microsoft EdgeHTML 17.17134 or later
> Mozilla Firefox® 38 or later
> Google Chrome™ 34 or later
> Apple® Safari® 8.0 or later

OS limitations are Windows XP Service Pack 3 or higher. All versions of OSX, and Linux are supported. 

If you are having display issues, please visit this site to discover which version of what browser you are on, and if there is an update available. If you need an updated version of a browser, or a new browser, please see the links below.

Internet Explorer
Firefox
Chrome
Safari on Mac

A Note Regarding Internet Explorer 9 or 10:
If you use Internet Explorer 9 or 10 to access FollowMyHealth, you need to make your browser compatible with TLS1.1/TLS 1.2.
 
To change the settings in IE 9 or 10:

  • Go to Tools and select Internet Options
  • Select the Advanced tab in Internet Options
  • Enable(check) TLS 1.1, TLS 1.2 and also disable (uncheck) SSL 3.0 for additional security
  • Click on Apply and OK to complete the procedure

 

Due to the restrictions of mobile devices, in order to use the FollowMyHealth UHR, you must have our mobile application installed. Please go here to check out our iPhone/iPad app and here for our Android app.

FollowMyHealth-SupportUS@allscripts.com
http://assets0.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete